New Tahoe Yukon Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey all,
Picked up our beautiful Z71 on Monday, Dec 28. Spent a few days getting to know her, and ordered and installed a roku stick for the kiddos in the back. All worked well on our first try.
Took a road trip to visit the parents, about 3 hours away. We started up the rear entertainment system, hoping to get some quiet time on the 4 hour drive. Less than a mile from our house, the system completely locked up! We turned the system off, unplugged the roku devices, and both screens stayed on for the duration of the trip. My daughter's screen had the youtube logo, my son's screen was black, but lit. This issue has persisted throughout the weekend. The screens do turn off once we are away from the vehicle, but every time we've tried to run the roku device again the same issue had occured. Calling the dealership tomorrow, of course, but why did we pay $2500 more for a system that doesn't seem to work reliably? Has anyone else experienced anything similar?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I took it to the dealership and they claimed it was the roku stick itself causing the issues. They said they used Miracast to stream a movie with no issues. The problem with Miracast is that I can't figure out 1. which specific Miracast app to download nor 2. how to get it set up and working. Too old for this tech, apparently. We have used the Roku stick with success once now, and put a small blu ray player in the car as well that we can hook up. My best guess is that spotty internet caused the glitch the first time-hopefully no more issues. All in all I do wish we'd skipped the add on and just went with tablet mounts and/or a portable DVD system. Much cheaper and easier to use.

Otherwise, the truck has been AMAZING. So fun to drive and it handles unbelievably well in the snow.
 

·
Registered
Joined
·
8 Posts
Hey all,
Picked up our beautiful Z71 on Monday, Dec 28. Spent a few days getting to know her, and ordered and installed a roku stick for the kiddos in the back. All worked well on our first try.
Took a road trip to visit the parents, about 3 hours away. We started up the rear entertainment system, hoping to get some quiet time on the 4 hour drive. Less than a mile from our house, the system completely locked up! We turned the system off, unplugged the roku devices, and both screens stayed on for the duration of the trip. My daughter's screen had the youtube logo, my son's screen was black, but lit. This issue has persisted throughout the weekend. The screens do turn off once we are away from the vehicle, but every time we've tried to run the roku device again the same issue had occured. Calling the dealership tomorrow, of course, but why did we pay $2500 more for a system that doesn't seem to work reliably? Has anyone else experienced anything similar?
I have a 2021 Yukon Denali XL I purchased three weeks ago. Had I known how crappy the entertainment system was I would have waited and purchased one without it. Literally the dumbest setup. The front of my car is Apple air play compatible but not the back?? The screens worked great using an hdmi cable for the first two weeks and now the hdmi inputs will not register its plugged in. Apple car play has also begun freezing in the front and to get it to “reset” I have to use a cord and connect it that way. I take it in for service in two days but what a major disappointment for such an expensive adder!
 

·
Registered
Joined
·
1 Posts
Hey all,
Picked up our beautiful Z71 on Monday, Dec 28. Spent a few days getting to know her, and ordered and installed a roku stick for the kiddos in the back. All worked well on our first try.
Took a road trip to visit the parents, about 3 hours away. We started up the rear entertainment system, hoping to get some quiet time on the 4 hour drive. Less than a mile from our house, the system completely locked up! We turned the system off, unplugged the roku devices, and both screens stayed on for the duration of the trip. My daughter's screen had the youtube logo, my son's screen was black, but lit. This issue has persisted throughout the weekend. The screens do turn off once we are away from the vehicle, but every time we've tried to run the roku device again the same issue had occured. Calling the dealership tomorrow, of course, but why did we pay $2500 more for a system that doesn't seem to work reliably? Has anyone else experienced anything similar?
Hi,

I just read your posts about your Rear Seat Entertainment and wanted to ask if any of you would be interested in the following study:

For our client, we are looking for interview participants who have a built-in Rear Seat Entertainment in their car. We would like to talk to you about your Rear Seat Entertainment and how your passengers use it.

The main criteria that must be met to participate in the interview:

  • The car should be no more than three years old
  • The car must have a built-in rear seat entertainment system
  • The rear seat entertainment should be used frequently

Interview details:

  • The interview will last max. 2 hours
  • Your participation will be sufficiently compensated
  • The interviews will take place until mid-December
  • If possible, we would also like to interview a passenger who often rides with you for 30-45 minutes (the incentive will increase accordingly).

I work for an innovation agency, HYVE Innovate GmbH in Munich, Germany, and would be happy to answer any further questions you may have about the interview. Feel free to reply here if you are interested. I look forward to hearing from you!

Best,
Soe
 

·
Registered
Joined
·
2 Posts
GM Pulled the Rear Seat Entertainment from the Yukon/Tahoe/Suburban for the rest of this model year.. this sucks..
is there an aftermarket rear seat entertainment system (either dual monitor screens or drop-down displays) that would connect to the front screen? not so much for watching on the front screen but i wanna be able to control it from the front screen.
Any info would be appreciated
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top